Music is gone 

Moderator: Moderatoren

9 Beiträge Seite 1 von 1
rtf54
Schurke
Schurke
Beiträge: 28
Registriert: 23.05.2012 10:25
Hat sich bedankt: 30 Mal
Danksagung erhalten: 4 Mal


Currently, I don't hear any music in the game. Location discovery sounds don't play either.

Battle music can sometimes get engaged, although once it does, it plays until the song's end even if the battle finished. After that, it's back to no music once again.
Music works on older saves, but there's no way I'm going back that far.
I have no idea how this started, and why it hasn't been able to fix itself.
I've tried entering all kinds of locations, and the only music I hear is Ark Marketplace lute.

Game is installed on C:\Program files (x86)\Steam. Removemusic commands didn't work.
I've got this map mod installed: https://steamcommunity.com/sharedfiles/ ... chtext=map
Dateianhänge
Saves.zip
(2.28 MiB) 4-mal heruntergeladen
Kermit 61
Moderator
Moderator
Schöpfer
Schöpfer
Beiträge: 1509
Registriert: 16.07.2016 11:15
Hat sich bedankt: 230 Mal
Danksagung erhalten: 383 Mal


Can you please report that in the bugtracker? You have to register separately.
Unfortunately, we can not find a solution on the fly.
You can refer to your post here.
rtf54
Schurke
Schurke
Beiträge: 28
Registriert: 23.05.2012 10:25
Hat sich bedankt: 30 Mal
Danksagung erhalten: 4 Mal


Thanks, will do.
Meldor
Krieger
Krieger
Beiträge: 40
Registriert: 21.06.2017 00:13
Hat sich bedankt: 6 Mal
Danksagung erhalten: 11 Mal


Try opening the console and type in : helpsilence

You'll see some music ID's, type in: removemusic "ID". Just don't remove the tavern music.
Maybe you'll encounter some infinite slience loop and with the removal of the ID's it goes back to normal.
urst
Moderator
Moderator
Schöpfer
Schöpfer
Beiträge: 1804
Registriert: 05.01.2013 16:15
Hat sich bedankt: 450 Mal
Danksagung erhalten: 489 Mal


25.02.2019 21:51Meldor hat geschrieben:
Try opening the console and type in : helpsilence

You'll see some music ID's, type in: removemusic "ID". Just don't remove the tavern music.
Maybe you'll encounter some infinite slience loop and with the removal of the ID's it goes back to normal.
yeah, usually that does indeed work.
in this case it doesn't :(
Riemenschneider
Lumpensammler
Lumpensammler
Beiträge: 7
Registriert: 20.07.2016 05:29


There seem to be a few people having that same problem right now. For example: https://sureai.net/tracker/view.php?id=983

removemusic does not fix this for me as well.
This is really weird, I experimented a bit with OP's and my own saves and found out several things:

Quicksaving during combat on a sound-bugged file (e.g. the one OP provided) and reloading that quicksave reactivates combat music, but a random one will be played.
This can include a combat theme that never plays in that location. Likely the one with which the bug was introduced into the save file?
So it's likely caused by quicksaving/loading during combat.
The random/unfitting battle theme is different for OP and me, mine is "Prey-Beutezug", for me it will also play e.g. in Ark or the Undercity, where it's never supposed to play.

Now it gets a bit more weird.
Reactivating the combat music by that method fixed music (in general) on pre-bug save files for me.
If you reactivate combat music by quicksave/reloading during battle and load another save file (with sound bug) that is NOT in combat, the unfitting combat music will play.
Other music will still not work though.
If you load the exact same (out of combat) save again, it will be silent again.

On sound-bugged files, the sound effects for discovering a new location and level-up don't play in game, but if you quit to main menu it will instantly play there (?)
So it somehow gets queued behind whatever is blocking the regular in-game music I guess?

Can anyone test it it behaves the same way for you guys? I attached 2 save files to this:
- 008: out of combat, right in front of an undiscovered location
- quicksave: in combat
Maybe if we try around a bit, we can find out how this bug is created in the first place.
rtf54
Schurke
Schurke
Beiträge: 28
Registriert: 23.05.2012 10:25
Hat sich bedankt: 30 Mal
Danksagung erhalten: 4 Mal


25.02.2019 14:43rtf54 hat geschrieben:
Removemusic commands didn't work.
Scratch that. removemusic _00E_SilenceLongTransitionHighPriority solved it for me. :)
found from here: https://sureai.net/tracker/view.php?id=983
rtf54
Schurke
Schurke
Beiträge: 28
Registriert: 23.05.2012 10:25
Hat sich bedankt: 30 Mal
Danksagung erhalten: 4 Mal


Update: It worked for the most part. Combat music hasn't seemed to work so far.
rtf54
Schurke
Schurke
Beiträge: 28
Registriert: 23.05.2012 10:25
Hat sich bedankt: 30 Mal
Danksagung erhalten: 4 Mal


Update2: Solved with hotfix provided at the bug tracker. https://sureai.net/tracker/view.php?id=983
9 Beiträge Seite 1 von 1

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast